trigger_teleport not working

Hi all,

I’ve been working on an elevator that uses a simple trigger_teleport not long after the player hits the button, which teleports them to the top floor/bottom floor.

Trouble is, for some reason it just won’t teleport the player. The destination is set, “clients” is ticked and I’ve tried using a point_teleport as well. No luck.

Is there something I’m missing?

Well if it has has the flags set to client, a info_teleport_destination set to the destination and the brush textured with the trigger texture (shouldn’t matter, but w/e).

Things to check:
Is it enabled?
Is the player inside the brush when they press the button?

Try remaking the brush if it’s an invalid brush that gets removed on compiling?

The brush fills the whole elevator, starts disabled, and upon pressing a button it enables it after a delay. And I used an info_teleport_destination first thing too.
Only thing I can think of is if it’s an invalid brush, so I’ll remake it.

Edit: Still doesn’t work… strange.

I cut this one out from one of my maps, it works for me.

Ok, so I figured out why my version wasn’t working.
I ticked ‘preserve angles even when a local landmark is not specified’ in my trigger, and it only worked when I unticked that as you had shown in your example.
Now I need to figure out the ‘local destination landmark’ string to preserve the position and angle the player was in when they were teleported.

You could use a point_teleport with Entity to teleport set to !player
I think it preserves the angles.

Founded in 2004, became one of the first online communities dedicated to Valve’s Source engine development. It is more famously known for the formation of Black Mesa: Source under the 'Leakfree Modification Team' handle in September 2004.