Need some help with model viewer

…As in, how do I get the dang thing to work?

This is the hlmv.exe located in Black Mesa’s own bin folder. For the life of me, I can’t get it to load models that use _anim files. Basically, NPCs. (Doing a slight mod of the character manifest and need the different attachments.

On top of that, how do I get it to load the model’s texture? Not extremely useful looking at a pink and black shape that sort of looks like an AC unit when I need to see what the AC unit looks like.

Sorry if this has been asked before. Maybe I’m blind, but I couldn’t find any threads on this. Please, correct me if I’m wrong.

Either way, any help with this is appreciated.

same here i can’t even get camera movement in the HLMV , but i have the Mod version which is in the sourcemods folder and the 2007 source SDK is set up and the HLMV in that works prefect, i guessing that theres no change in the models from the retail or mod version in the way they have there attachment points maybe you could try dl’ing the Mod if you don’t have it and use the old sourcesdk HLMV to find the attachment names then do your changes in the retail version

It works for me I think? Just make sure you have steam on,
Open hlmv.exe, File->(Steam) Load model.

I get the “Can’t open folder” on blackmesa unique folder names, but if I lookup the filepath in hammer and paste it, I can open the models located in those folders.
(Make sure u replace the / with [b][/b])

I managed to get the static models loaded. The problem is the NPCs. For instance, my path to the marine.mdl file:
c:\program files (x86)\steam\steamapps\common\black mesa\bms\models\humans\marine.mdl

Once I unpacked the models, I can open it, but it immediately throws up this error:
Model models/combine_soldier_anim.mdl not found and Model models/error.mdl couldn’t be loaded.

Also, attempting to paste the file path, even with the models unpacked, makes the program claim that the model doesn’t exist. I can only manually load it, which produces the above.

I did try unpacking the combine soldier animation model, but it still claims that it can’t be found. As far as I can tell, the model viewer is completely FUBAR.

Big surprise there…

i got it to work i made a shortcut then on the target line i put -game “C:\Steam\steamapps\common\Black Mesa\bms” the full directory info is needed now the models including NPC’s display and play any anim’s they have hope this helps :slight_smile:

Don’t use the whole path when trying to open them.
When you use File->(Steam) Load Model, you’re already in the models folder.

No need to unpack any models.

So all you need to do is put in: \humans\marine.mdl

I tried both your solutions, still no dice. Model viewer still claims that the model does not exist. However, it also doesn’t show any of the model folders like you have LordDz. I have no idea how you got yours to work, but mine doesn’t. Things busted, as per SOP.

Quick stupid questions:

  1. Are you making sure that you’re using File->(Steam) Load Model and not the Load Model function?

  2. Did you replace the / in the model path with \ ?

Post screenshots how it looks for you, it helps.

Yes to one, no to two.

Model browser for me:

Founded in 2004, became one of the first online communities dedicated to Valve’s Source engine development. It is more famously known for the formation of Black Mesa: Source under the 'Leakfree Modification Team' handle in September 2004.