How to report an issue

Every time the game crashes, it will create an DMP (minidump) file in your \Steam\dumps folder. Your crash will be the newest entry in that folder named something similar to crash_bms.exe_20150505021705_1.dmp. If you attach the file to your report, it will help us track down and solve the issue

Performance Issues[/size]
If you have generally low performance, try decreasing your graphical settings. If your computer is lower-end, you should be lowering the display resolution, dropping the texture detail and disabling settings such as anti-aliasing. If you’re getting noticeably worse performance than usual in one particular area, grab a screenshot of the problematic area with the showbudget panel enabled so we know where to start.

When in the options menu going under the keyboard tab and hitting the advanced button will allow you to check the box to enable the developer console. Hitting the Tilde key will open the console once the option has been checked (Its located directly below your escape key and to the left of your 1 key)

Type +showbudget in console will display the showbudget panel
Type -showbudget will hide this panel again

If you find something that doesn’t behave as intended or you would expect, grab a screenshot and getpos information.

Type ‘status’ into your console and get the map name.
Type ‘getpos’ into your console, and copy-paste the co-ordinates it spits out.

Explain in your post what you were doing, what you thought should happen, and what did happen.

If you find that a weapon or NPC can be exploited, write down what you did and how you did it. If you find a portion of a map that can be exploited, grab a screenshot and getpos information (as above) and explain what you did and how you did it.

1 Like

Question; May we have a section for reporting cosmetic problems and game-play problems that aren’t necessarily bugs? Such as incorrect lighting on specific maps, menus not working correctly and geometry collision causing movement flow problems?

And may we have .dmp files added to the list of allowed attachment formats?

Go for it, though I cannot guarantee if all minor cosmetic issues reported will be fixed.

Also .dmp should be added to the allowed list asap.

Found this guy under platform…


3840x2400 downscaled to 1920x1200:

Game crashed while trying to load Scientist (Alternate) /humans/scientist_02.mdl in the multiplayer customization menu.

Also, much more minor issue, but immersion-breaking all the same, func_breakable_surf can no longer be “cleared away” by the crowbar - after the initial hit to shatter it, the crowbar will no longer hit it, meaning no further shards can be taken out. Physics props, bullets, and explosions all still affect the entity.

One last thing I noticed, is that Eli’s wrist clips through his labcoat - I’m pretty sure this didn’t happen before.

cl_ejectbrass 0 doesn’t work.

Shooting NPCs don’t spawn shells =(

Shells are clipping throw floor:

How do I increase the size of the +showbudget panel? It’s too short at the moment, so all the labels are scrunched up and unreadable.
I’ve tried editing the config.cfg file but unfortunately this seems to get re-written whenever I start Black Mesa. I’m getting occasional rate-drops and I’m interestd to see why it’s happening.

Can’t close some doors after opening:

Fire doesn’t inflict damage:

So i found this bug on bm_c3a2c map.

and on the other side same bug.

Got stuck in dm_bounce, by some pipes.

View while stuck:

(Forgot to getpos, sorry)

Also, bouncepad not rendering:

I also had an issue where after being killed by an explosion, the tinnitus didn’t go away - even after respawning. I had to disconnect from the server to get rid of it. Wasn’t able to reproduce, which, for me, was a relief.
Use hearing protection, kids.

Invisible wall for the flare?

Box on the conveyor belt

Can’t destroy TV on walls with a crowbar

Strange sqare shadow (appears on random locations)

Bullsquid hurting through the wall

Got stuck falling between some pipes in bm_c3a2e at 445.193420 39.994865 -43.516922
It was possible to get out with the use of explosives, but not through gravity.

you can hold tau cannon secondary fire forever if you zoom in while charging

1)map : bm_c1a2c at: -956 x, -276 y, -231 z
When I failed the first jump across the elevator shaft at the end of Office Complex, the fall didn’t quite kill me. There wasn’t a ladder down there, so I had to reload.

2)Houndeyes seem to have a physics boundary slightly too small for them, so the tips of their eyes can push through doors.

3)I’ve noticed that every time a train car I’m riding goes from a flat to an inclined section of track, I get pushed a few feet back from the control panel of the train. I’ve lost control of the train as a result of this a few times.

  1. map : bm_c2a5e at: -173 x, -484 y, 43
    In the booby-trapped warehouse, you can continue to fire your gun for several seconds after setting off what should be a fatal explosion.

  2. map : bm_c2a5f at: 236 x, -3343 y, 416 z

If you quickly shoot down the osprey from the ramp where you enter the area, none of the aliens that spawn in recognize you as an enemy. They just stand there staring off into space. You can even shoot some with no reaction, but killing a grunt seems to finally get their attention.

6)Alien grunts still give their death sounds even if you’ve blown them into tiny chunks.

  1. map : bm_c3a1b at: -1635 x, 38
    When you first take the elevator down to Lambda, there is a bit where some HECU roll a flaming barrel down some stairs at you. It’s possible to bait them out so you can kill them before they can do this, but if you walk down that hall later you still trigger the barrel rolling down at you with no one to push it. I’d only spawn them AFTER the barrel is pushed. You’ve got a conveniently place elevator to put them in.

8 ) map : bm_c3a2e at: -183 x, 1288 y, 840 z
The crawler zombie ambush down the ladder by the coolant tanks is pretty odd given that there is NO WHERE FOR HIM TO COME FROM. I don’t mind that he spawns behind you, but if you put a small vent in that room there is at least somewhere for him to logically come from.

  1. map : bm_c3a2h at: 575 x, 69 y, 64 z
    In the final portal chamber, green light from the portal seems to be leaking out onto some of the walls before the shields are lowered.


Player can get under (and sort of inside) the rocket:

Also it is possible to not kill grunts and launch the rocket:

map: bm_c2a3a
getpos: setpos 1306.955688 -1002.253357 -1146.823730;setang -61.729931 56.355885 0.000000

The underwater effects for bullets seem to be missing.
At the beginning of the level apprehension, you crash your train into the water and marines start shooting you from above. Their bullets show no bubble traces underwater.
Same is true for when you fire your glock underwater.

Two images show what it looks like now (no air bubbles).
The other two show what it looked like in the mod (air bubbles).

Bug 1: The command console is flooded with the phrase “Cannot update control point 1 for effect ‘flashlight_firstperson’.”

Typing the following into the console removes the flooding. (Thanks to UnintelGen)

Alternatively, adding

this .cfg file[/attach] to the SteamApps\Common\Black Mesa\bms\cfg folder, and then typing “exec StopConsoleFlood.cfg” into the “autoexec.cfg” file and saving it will also remove the flooding.

Bug 2: In the “Black Mesa” menu, I’ve checked “always run”, but I still go at normal speeds and have to hold shift to sprint. Also, it seems that the Houndeye tinnitus isn’t on either, despite being checked.

Bug 3 (maybe): It seems I can pick up dead headcrabs and human body parts? I’m not sure if that’s a bug or not (as it hasn’t been in any other HL games), but it should be kept!
Edit: Ok, it seems I can only pick up SOME dead headcrabs. All of these headcrabs I’ve (so far) encountered were not just dead props, they were headcrabs that I’ve killed myself. Yet some ARE able to be picked up, and some aren’t.

(Very Very Very Minor) Bug 4: When hitting this (unbreakable) vent in this spot, there is no noise, and the crowbar moves slower, as if hitting air. Obviously this isn’t important at all, as the vent is unopenable, and doesn’t break/hinder gameplay, but I thought I may as well mention it.

Bug 5: I had a security guard and scientist (female if it matters) following me, and when I killed the security guard, the scientist praised me, (saying things such as “Good show!”, or “Good show, Freeman, good show!”). I tested this a few times and the results were the same.
The opposite worked normally. Shooting the scientist caused the security guard to turn hostile.

u Bug 6[/u]: Not sure if this is a typo or not. It may be signin, sign in, sign-in, or signing: (262 Bytes)

Bug 7: Just a physics bug. After breaking the crate that’s blocking the generator from working, an oil can (a prop found when opening some crates) started flying around the room. Click here for pictures and my position/map details.

Bug 8 b[/b]: The rails in “On a Rail” aren’t electrocuting me as they did in the original. Without the electrified rails, there isn’t much point in using the cart, is there?

Bug 9: This marine wouldn’t notice me until I got quite close to him.

Bug 10: This crate in “Residue Processing” seems to be set to NoCollide. Gordon can walk through it and weapons act if if they’re hitting air. I can’t seem to upload the pictures and map/position here, but here they are on imgur.
EDIT: This also happens with the rest of the wooden props in the water, but they can be picked up.

Bug 11: I have also seen the boxes in the shadows, like “mr.StevenS” has. I didn’t take a screenshot, but I remember it happening when I first encountered the Black Ops.

map: bm_c2a5a
getpos: setpos 1011.971191 5249.616699 1664.031250;setang 34.088036 -88.007919 0.000000

Gravel acts like a wet surface. So when you stop walking you slide a bit.
Though you don’t slide as much as on actual wet surfaces, so this might be by design.

Map: bm_c2a5e at: -2643 x, 454 y, 44 z
Getpos : setang 7.086182 -46.642456 0.000000 setpos -2643.296875 454.859161 44.454597;

I go to open the secondary door, but before it opens, i get the loading icon, then just white screen, explosion sounds, dead, reloading brings me right back to the white explosion and dead. Doesn’t matter where i go in that area.
Grabbed a video since idk how well a screenshot would explain.

Founded in 2004, became one of the first online communities dedicated to Valve’s Source engine development. It is more famously known for the formation of Black Mesa: Source under the 'Leakfree Modification Team' handle in September 2004.