Help me finish my first-ever sound mod (Sound.cache problem?)

So I’m not a total newbie; I’ve been doing some form of game development since 1998, but I’ve never done tons of Source modding before so I don’t understand the finer details.

I’ve gotten as far as generating a VPK for my sound mod. That local VPK works in Black Mesa just fine, but when I feed it through the Publishing Tool and try to subscribe to my own mod, suddenly it stops working and the console gets flooded with error messages like

Cannot figure out which search path sound\npc\alien_slave\vort_bm_alert01.wav came from. Absolute path is D:\Steam\steamapps\workshop\content\362890\1969844684\Classic Alien Slave Voice.vpk\sound\npc\alien_slave\vort_bm_alert01.wav
Failed to load sound

Searching these forums suggests I might need to build a soundcache to include with my VPK. Black Mesa seems to automatically generate a soundcache for my VPK after loading it the first time, so I point the Publishing Tool at the folder with the VPK + sound.cache file, but, again, the console is flooded with search path errors when it comes back down off the workshop.

Another thread from two years ago mentions a console command called “snd_buildcache”. So, instead of using the sound.cache file generated for my VPK, I copy all of my sound files in the proper folder structure in to bms and build a cache.

This leaves me with

bms\aslave\sound.cache (664kb)

Which was built from

bms\aslave\sound\npc\alien_slave\ (62 files, 11.7mb)

I repack my VPK, publish it, and yet again, it’s the same story: the local VPK I generated works fine for me, but trying to pull it off the workshop doesn’t work because it’s yelling about search path errors.

What am I missing?

For reference, here’s my VPK:

So after digging around in other people’s (functional) sound mods, I saw that none of them contained soundcaches or manifest lists or anything like that

Prefacing this, in my original attempt, I tried snd_restart to get my workshop submission to work and for some reason it did not.

Which is to say… this time it worked? This is just the same sound bug that effects everyone and for some reason I got buried in a weird version where snd_restart didn’t take at first. Maybe it built a bad cache originally? I honestly don’t know.

Anyway, it’s fine now. Or as fine as it can be.

Founded in 2004, became one of the first online communities dedicated to Valve’s Source engine development. It is more famously known for the formation of Black Mesa: Source under the 'Leakfree Modification Team' handle in September 2004.