Unable to bind keys

i have tried to remap my controls to what i use in all other games, including source engine games without issue.
BM however seems to not allow these changes. specifically im trying to use the right side of the keyboard, numpad keys, numpad ins, enter, Rshift, RCtrl etc but cant. i have seen left handed players on discord complaining about similar, any walkaround anyone can suggest?

A workaround is to launch the game with the old UI by adding -oldgameui to the launch options, and then do your mappings there. Afterwards, you can remove the -oldgameui option and the bindings will continue to work with the new UI.


Same problem here, and the cheap workaround worked for me :+1:
Seriously, not being able to rebind the Return key is insane… Been doing that 20 years ago, for every HL mods around without problem so far (Return <> Use for people using arrows instead of ZQSD)

ZQSD? How does that work?
WASD makes way more sense… Or, <AOE, in my case, since I use Dvorak. If I’m honest, that’s a whole 'nother can of worms.

AZERTY layout (French).

I had the same issue, some of my mouse buttons (Logitech G602) are set to keyboard key numbers from 1 to 6.
I use 4 to activate stuff in game.
I was able to set up my mouse button “4” in the binding menu, but in-game, the mouse button wouldn’t work. Only the two “4” keys from my keyboard would work.

Using the old interface has done the trick. Thanks @Flavrans!

Ah! Merci!
Makes way more sense, now.

Founded in 2004, Leakfree.org became one of the first online communities dedicated to Valve’s Source engine development. It is more famously known for the formation of Black Mesa: Source under the 'Leakfree Modification Team' handle in September 2004.